How to change banner image or banner-login-search form layout?

Feb 20, 2012 at 4:43 AM
Edited Feb 20, 2012 at 5:27 AM

Thanks for cool skin! 

I have some questions for this skin.

First, how to change default banner image?

Second, how to change skin layout? (change bannder, login, search form position)

Thanks!

 

Added : I found some bugs.

In chrome 17 and host account logged in, main menu  which has child pages are not work. When I click menu, there is no changing page. No mouse hover effect. In IE 9.0, all menus are work correctly.

And when I used GraySmallTitle module container, Entire page layout is collapsed. (In IE, chrome, firefox)

My dnn is lateset community edition with 2 language.

Coordinator
Feb 21, 2012 at 11:50 AM

The images of the banner slider could be changed in the Banner folder of the skin, by replace the existing images, and/or the Banner file names could only be changed in the index.ascx file.

To change skin layout you have to modified the index.ascx and skin.css file. 

About the bugs, I have to inverstiged in it, and need some time for it.

Coordinator
Feb 23, 2012 at 9:18 PM

I have reproducve the issue with the GraySmallTitle Container, and added in issue to the issue tracker.

But I could not reproduce the issue with the menu on Chrome 17 browser.  Childpages worked on Start/Home and other menues, also the mouse hover worked there.

Coordinator
Mar 1, 2012 at 1:02 AM

The issue with the GraySmallTitle container is fixed and would be released with the next version soon.  Any news about your menu issues?

Mar 3, 2012 at 2:36 AM

Menu issue is not fixed for me. It occurred in chrome only. IE, Firefox works fine.

Coordinator
Mar 3, 2012 at 5:27 PM
Edited Mar 3, 2012 at 5:35 PM

Could you tell me the chrome version and the color of the skin please?  Also please tell me the complete No of your DNN Version !  On the blue and orange Metro7 skin Chrome Version 17.0.963.56 works as aspected with submenus using DNN 6.1.3 revision 108.

 

Mar 4, 2012 at 2:09 AM

My test pc and DNN environmental is completely same with yours. and I used "Metro 7 - Index" skin.

I uploaded my situation screen shot with comment. Please see this.

https://skydrive.live.com/redir.aspx?cid=e588ca3d98b049f4&resid=E588CA3D98B049F4!3458&parid=E588CA3D98B049F4!1973&authkey=!AHH8hQcX1aXUOE0

Coordinator
Mar 4, 2012 at 5:51 AM

Could be an issue with your admin permissions.  Cpould you try to create a new user, and dobble check, if the issue also exist with ene new user?  I could not reproduce your issue with the menu.  If the issue still exist please tell me a mail or MSN adreess to contact you directly.

Thanks

Matthias

Developer
Mar 4, 2012 at 5:25 PM

I was able to reproduce the menu issue. It is due to javascript errors in the implementation of the SolPartMenu component. I don't think much can be done, except use a different DNN menu, which I strongly recommend. I'll discuss changing the menu provider for the next version with Matthias.

Coordinator
Sep 12, 2013 at 4:00 PM
This should be already fixed on 6.x Versions and newer.